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EXCEL TRAINING WORKSHOP
CHEMISTRY 315 – INSTRUMENTAL ANALYSIS

PURPOSE

The purpose of this workshop is to familiarize you with the basic operations of Microsoft Excel. Excel is a
spreadsheet program that is extremely useful for data analysis and presentation. You likely will use the
program throughout this semester and your career.

In this workshop, we will cover data entry, formatting of data, mathematical function entry, graphing,
formatting of charts, and linear regression. We will conclude with a few examples relevant to this course.

Please realize that this workshop is only an introduction to Excel. In order to fully realize its power and
become comfortable with the interface, you must spend more time becoming acquainted with the
program.

DATA ENTRY

After starting Excel, you will see a grid with alphabetic labels across the top and numeric on the left-hand
side. The alphabetic labels refer to columns, and the numeric labels refer to rows.

•  Click on one of the alphabetic column labels. Notice that the entire column becomes highlighted.

•  Click on one of the numeric column labels. Notice that the entire row becomes highlighted.

Each box of the grid, called a cell, has a unique name defined by its column and row. For example, the
top left cell is called A1.

•  Click on the top left cell. A darkened box surrounds it, and the column and row labels are bold. Just
above the spreadsheet is a box that contains the label A1.

•  Try clicking on other cells and notice how the column and row labels change.

For an introductory example we will enter data for a fictitious company.

•  Type “Month” in cell A1 and “Sales” in cell B1.

•  Type Jan 97 and Feb 97 in cells A2 and A3, respectively.

•  Highlight cells A2 and A3 by clicking on A2 and dragging to A3.

•  Position your cursor on the tiny box in the lower right of the highlighted cells. Your fat cross cursor
will change to a skinny one. Click and hold the left mouse button and drag the cursor down to row
18 in column A. Excel will auto-fill the correct dates in the cells.

•  Manually enter numeric data in column B.

FORMATTING OF DATA

The data you enter in Excel can be formatted in many different ways.

•  Highlight the numeric data in column B. Be sure you do not highlight the heading “Sales” in cell B1.

•  Click on the Format menu, then select Cells, then Currency. You will see a variety of options for
formatting the values in these cells. You can set the number of decimal places, whether to include
the dollar sign, and how to express negative numbers. For now, select the default settings by
clicking OK.

NOTE: There are two other simpler ways that you could have formatted this column. Highlight the cells
again, and click on the right mouse button. A pop-up menu will appear. Select Format Cells. A dialog
box appears that has several tabs on the top. Click on the Number tab. You can now set the formatting
here. The second way to format the cells is using the Toolbar just below the menus at the top of the
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screen. Highlight the cells again, and click on the dollar sign button. This applies the default currency
formatting. If you want to change something, such as the number of decimal places, you must use one
of the other two methods.

The dates can also be formatted differently. See if you can change the format from Jan-98 to
January-98.

FUNCTION ENTRY

One of the most powerful features of a spreadsheet is to perform repetitive calculations on large sets of
data.

•  In cell C1, type “Commission”. In cell C2 type “=B2*0.063”. This simple formula will calculate your
commission at the rate of 6.3%.

•  Fill in the remaining cells by clicking on cell C2 and dragging the tiny box in the lower right corner of
the cell (using the skinny cross cursor) down to cell C18. This copies the contents of C2 down while
updating the reference cell.

•  Click on cell C14. Notice that the formula is now “=B14*0.063” instead of “=B2*0.063”.

NOTE: A quicker way to fill down is to simply double-click on the tiny box in the lower right corner of the
cell.

What if you don’t want to update the cell references as you fill down? Let’s assume that we want to
calculate the commission based on different rates.

•  In cell D1, type 0.04 (or 4% - Excel automatically converts percentages to decimals when performing
calculations). In cell E1, type 0.08 (or 8%).

•  In cell D2, type “=B2*$D$2”. The dollar sign in front of the column and/or row tells Excel not to
update that cell reference, so each cell in column D will calculate the commission based on 4%. Type
the appropriate formula in cell E2 to calculate the commission for 8%.

•  Fill in the numbers to complete the table.

Excel contains many other functions. Use * for multiplication, / for division, + for addition, – for
subtraction, and ^ for exponent (e.g. 10^3 = 103). You can use trigonometric functions (e.g. SIN is sine,
COS is cosine), statistical functions (e.g. AVERAGE, STDEV is standard deviation), and many other
functions (e.g. SQRT is square root, LOG is base 10 log, LN is natural log). To find out about a particular
function, search for it using Help or search for “functions, overview” in the Help Index to find a
comprehensive list of functions.

For now, let’s do some simple calculations on your commissions.

•  In cell C19, type the formula “=SUM(C2:C18)”. This sums the values in the data range C2 – C18.
Note that a colon must separate ranges. If you used a comma, only cells C2 and C18 would be added
together. Repeat with columns D and E.

•  Find the highest monthly commission entering the formula “=MAX(C2:C18)” in cell C20. Find the
lowest monthly commission using the function MIN, and the average monthly commission using the
function AVERAGE. Repeat columns D and E.

NOTE: Using functions can be tricky, especially if they are complex. Double-check your formulas before
relying on the answers. Often misplacement or misuse of parenthesis can lead to an unintended
calculation.

CREATING CHARTS

We’re ready to plot some data. Close the present spreadsheet by selecting Close from the File menu. Do
not save the file. Create a new spreadsheet by clicking on the button on the top left that looks like a
piece of paper. Enter the following data in the spreadsheet:
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Iron Concentration (ppm) Absorbance

0.00

0.50

1.00

1.50

2.00

2.50

-0.0409

0.3841

0.7898

1.227

1.606

2.047

•  Highlight the data that you entered by clicking the first cell and dragging over the entire range.

•  Click on the Insert menu and select Chart. Alternatively, click the button on the tool bar that looks
like a bar chart.

•  The Chart Wizard will guide you through the process of making a chart. First, click on XY (Scatter).
You should never choose a chart type other than XY (Scatter) when making a graph for
this class. A series of chart sub-types appears in the right portion of the dialog box. Select the first
sub-type (data points with no lines). This is the sub-type you should normally choose. Click Next. A
sample of your chart appears. Click Next again.

•  The next dialog box is where you can set several options. Note that there are tabs at the top of the
box. Step through them one at a time. Type “Calibration Curve for the Determination of Iron in
Water” in the Chart Title box. Enter “Iron Concentration (ppm)” and “Absorbance” for the X and Y
axes, respectively.

•  Select the Axes Tab. Make sure both boxes are checked.

•  Select the Gridlines Tab. For this course, it is preferred that the charts have no gridlines.

•  Select the Legend Tab. Uncheck the Show Legend box. You should only use a legend when more
than one set of data is presented on the same chart.

•  Under the Data Labels tab, ensure that None is selected. Click Next.

•  Select As New Sheet, and enter a descriptive name for the chart, such as “Calibration Curve”. Click
Finish.

Your calibration plot should now appear. Look on the tabs near the bottom of the screen. There should
be one tab with the description of your chart (e.g. Calibration Curve) and a few other tabs. Click on the
Sheet1 tab. This is your spreadsheet. Click on the tab to go back to the chart.

FORMATTING CHARTS

To format a chart, you merely double-click on what you want to change.

•  Double-click on the chart title and type a new title. You can also change the font, insert special
characters, etc. Do the same thing with the X and Y axis titles.

•  Double-click on the chart background. Be sure not to click on a gridline or a data line. If you don’t
like the gray background, change Area to None and select OK.

•  If you don’t like how Excel has chosen the scale, double-click on the appropriate axis. Select the
Scale tab and enter the minimum, maximum, major unit, and/or minor unit. Again, there are several
things to change here; don’t be afraid to play around.

NOTE: If you make a change that you don’t want to keep, select Undo from the Edit menu (or click the
Undo button on the toolbar, or press control-z). This will undo the last change you made.
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HINT: Another useful feature of Excel is the right mouse button. Try pointing to an object and clicking
on the right button. You get a pop-up menu with several different options. Experiment with this – it is a
great time saver. (This feature is available in most newer computer programs for the PC.)

LINEAR REGRESSION

Excel has a built-in tool to calculate and display linear regressions on charts. This is the quickest way to
calculate a linear regression for your chart.

•  Click with the right mouse button on one of your data points. A pop-up menu appears, and Add
Trendline is one option. Select this. (If Add Trendline is not one of the options, you did not click close
enough to a data point. Try again!) A dialog box with several options appear. Normally, you will
select Linear, but notice all of the other types available.

•  Click on the Options Tab. Select Display Equation on Chart and Display R Squared Value on Chart.
Other things you can do here are select a name for the Trendline, forecast the line (i.e. extend the
line beyond the data points), and force the regression through zero (never use this unless you are
constructing a Beer’s Law plot or you have another reason why the data should go through zero).

•  Click OK. The graph appears with the Trendline plotted and the equation of the line displayed. You
can move, edit or format the equation using the techniques described under Formatting Charts
above.

The last step is normally to print out the chart. You can do this by pressing the Print button on the
toolbar, or by selecting Print from the File menu.

FINAL SUGGESTIONS

•  If you’re stuck, try the help. The Office Assistant can be very annoying, but also very powerful. Press
F1, click on the Office Assistant, press the Help button on the toolbar, or select Microsoft Excel Help
from the Help menu.

•  Play around with the right mouse button. You will find it extremely useful in most circumstances.

•  Save your work to a floppy disk often. Like all programs, Excel can crash, and it will likely happen
when you are approaching a deadline.

•  Don’t be afraid to experiment! You can almost always get out of a jam by using the Undo function.
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EXAMPLES

1. Derivative of a function.

Excel can be used to calculate the derivative of a mathematical function. In this example, we will
graph the function
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a. The first step is to enter the range of x. For this problem, enter values from –2 to +2 in steps of
0.1 in column A. Use the Auto Fill feature to speed up the data entry.

b. Enter the function in column B. To do this, you must replace x in the equation with the
appropriate cell reference. For example, if the first x data point was in cell A1, the formula would
be “=x/(1+x^2)”. Note that the denominator must be in parenthesis since we wish to divide x by
the entire value of 1+x2. If you just entered “=x/1+x^2”, you would be calculating the eqution
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c. To calculate the derivative, we will assume that
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Enter the formula for the derivative in column D. You will have one less data point in this column
than you have in columns A and B.

d. Next, we must place new values of x in column C. Because the derivatives calculated in column D
are the combination of two values of y at two different values of x, ∆y/∆x (column D) should be
plotted at the midway between the corresponding x values. Therefore, in Column C place the
average of the x values used to calculate ∆y/∆x.

e. Make two separate plots of the function and the derivative.

2. Statistical Analysis of Data

Excel can be used to calculate the average, median, standard deviation, variance, and confidence
interval for sets of data. For example, calculate these quantities for the following separate sets of
data:

Set 1 Set 2

2.31017

2.30986

2.31010

2.31001

2.31024

2.31010

2.31028

2.30143

2.29890

2.29816

2.30182

2.29869

2.29940

2.29849

2.29889

a. Enter these values in columns B and C starting at row 1. Change the formatting for these cells to
6 decimal places.
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b. In cells A9 – A15 enter the labels “Average”, “Median”, “Standard Deviation”, “%RSD”,
“Variance”, “CI (90%)”, and “CI (99.9%)”.

c. Enter “=AVERAGE(B1:B7)” in cell B9. Fill in the remaining cells with the appropriate functions. To
calculate the confidence interval, use the TINV function. The TINV function has two arguments,

the first of which is the probability (
100

%)(inLevelConfidence
1 −= ), the second of which is the

degrees of freedom (= Number of Measurements - 1). Therefore, for the first set of data, the
formula for the confidence interval is “=TINV(0.1,6)*B11/SQRT(7)”.

3. Multiple Linear Regressions

Sometimes it is necessary to calculate the linear regression for more than one set of data. For
example, a plot may have two different linear regions, requiring separate linear fits for each portion
of the curve. The following data exhibits two linear regions with an inflection point near a
concentration of 1.0:

Concentration (ppm) Absorbance

0

0.2

0.4

0.6

0.8

1.0

1.2

1.4

1.6

1.8

-0.0092

0.1417

0.2079

0.3363

0.4580

0.8414

0.9831

1.2901

1.3931

1.6186

a. Enter the data columns A and B.

b. Select the concentration and absorbance data from 0 to 0.8 ppm. Create a scatter chart with a
Trendline using this data set.

c. Select the concentration and absorbance data from 1.0 ppm to 1.8 ppm. On the Edit menu,
select Copy. This places the data in a temporary storage space called the clipboard.

d. Click on the tab for your chart and select the chart by clicking on it. From the Edit menu, select
Paste Special. Select New Series and make sure Categories (X Values) in First Column is checked.
This creates a new set of points in the chart. Note the different color and shape of the new data
points. You can now insert a Trendline for this set of data.


