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Imaris Surpass 3D View Interface 

1. Object List 
All components in the 
scene are represented 
here in a tree hierarchy 

2. Object Properties 
Analysis Parameters, 
Visualization Settings, 
Statistics.... 

3. View Area 
3D Rendering of Objects, 
and 3D Workspace for 
Navigation, Selection, 
Interaction, and Editing 

4. Display Adjustment 
Color, Max/Min Intensity, 
Opacity, Gamma 
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5. Object Labeling (for coloring and statistics export) 
Add labels to 3D objects such as spots, surfaces, cells, 
vesicles, etc. The labels can be used to color code objects. 



Global Functions 

Display Adjustment: 
 

View Adjustment Buttons 
 



View Adjustment Buttons 

q  “Zoom” 
q  preset zoom factors 

q  “Fit”  
q  Fit image to window size 

q  “Reset” 
q  Rotates the image to the original 

position  
q  centers the image 
q  Fit image to window size 

q  “Full Screen” 
q  Enters Full Screen mode.   
q  Click again to exit full screen mode. 

q  “Navi” (Navigation window) 
q  Inset image of entire dataset 
q  Yellow box shows current zoom position 



Mouse and Keyboard in Imaris  

Frequent Commands and their Keyboard Shortcuts 
 
•  “Esc” key 

•  Toggles Surpass pointer between Select / Navigate 

• “Ctrl + D” (OSX: Command + D) 
•  Show / Hide Display Adjustment Window 

• “Ctrl + I” (OSX: Command + I) 
•  Opens the Image Properties window 

• “Ctrl + P” (OSX: Command + P) 
•  Opens the Imaris Preferences 

 

Main Mouse Interactions 
 
•  Scroll Mouse wheel: 

•  Zoom in/out 

• Right-click & drag: 
• Pan image 

• Left-click & drag: 
• Rotate image 

 
 

 

Shortcut to Keyboard & Mouse Guide: 
 
•  Click Help -> Keyboard and Mouse  



Display Adjustment 

Controls: 
•  Channel visibility 
•  Channel color 
•  Intensity range min/max 
•  Blend Opacity 

 

Displays: 
•  Channel intensity histogram 

 

•  Click on checkbox to control 
channel visibility 

•  Click on triangles to control 
min/max/gamma 

•  Drag on colour bar to control 
intensity (left/right) or contrast 
(up/down) 

•  Click on channel name to get 
to colour dialogue 

•  Right click drag on colour bar or 
use slider to adjust blend 
opacity (left/right) 

•  “Reset” reverts to default 
•  “Auto” selects min and max 

values in each channel 
•  “Auto Blend” selects “optimized” 

min/max values for blending  
 

Open the Display Adjustment 
Window: 
* Short cut: Ctrl-D 
* More menu -> Edit menu > 
Show Display Adjustment 



Display Adjustment: The Color dialogue 

•  Select Base Color to show the channel with one specific color 
•  Select Mapped Color to map intensities of one channel to multiple colors 
•  Create your own color map by editing the color for specific intensities and 

Interpolate the colors for the intensities in between 
 



Scale Bar 

• To adjust the length of the scale bar, 
drag on one end of the scale bar 

• To adjust the height of the scale bar, 
drag the top or bottom of the scale bar 

• To move the scale bar position, drag 
the center of the scale bar 

• To adjust the size of the font, drag the 
top of the text 

In the 3D Perspective rendering mode of Surpass, the bar is scaled for the center of the dataset 



Volume Rendering 

MIP 
•  Only the brightest point along the 

viewing direction displays 
•  Combination colour of different 

channels is displayed 
•  Opacity settings are ignored 

Blend 
•  All values along the viewing 

direction including their 
transparency are used 

•  depth effect, edges appear 
dark 

•  Effect: data closest to the 
view is visible while the data 
further away is obscured  

MIP                                       Blend 



Normal Shading 
•  Uses artificial light source 
•  Surfaces turned away from 

light source appear darker 
•  Depth effect 
•  Light source can be 

interactively positioned,  
•  Light intensity not adjusted 

 

Volume Rendering 

Shadow Projection 
•  Uses artificial light source 
•  An object between light source 

and the displayed object 
projects a shadow to the object 

•  Not an interactive mode 
 

Normal Shading Shadow Projection 



Basic Views I: Slice View 

•  View individual Z-slices 
 
•  Browse through your Slices 

using a Slider 
 
•  Inspect intensities under 

mouse pointer 
 



Basic Views II: Section View 

•  Interactive view on XY, XZ and 
YZ sections 

 
•  Define the sections you want 

to see by moving the crosshair 
 
•  Get an impression of the 

organization in all dimensions 
 
•  Render Extended Sections in 

3 different projection modes 
• Adjust thickness with yellow lines 

 



Basic Views III: Gallery View 

•  Get an overview of 
multiple z-slices at once 

 
•  Choose a subset of slices 

you want to display from 
the gallery with Select… 

 
•  Organize the columns of 

your gallery 
 



Basic Views III: Easy 3D View 

•  Get a simple 3D 
projection of your 
dataset along Z 

 
•  Choose between two 

different projection 
modes 

 
•  Illuminate the scene 

from 2 different 
directions to project 
shadows 

 
•  Great for quick look at 

data (though slow for 
large datasets) 

 



Volume Draw Tab 

1.  Choose Painter Shape 
2.  Place painter by Shift + Left Click 
3.  Set intensity of voxels in painter 

region 

-  Fill a small region with high intensity to force a known connection 
-  Fill a small region with 0 intensity to force a known break, or 

create a visualization “window” to the inside of a structure 
 



Clipping Plane 

Use this rod to 
freely rotate the 
plane 

Use this rod to 
change the 
position of the 
plane 

Only cuts objects lower in 
Objects List 



OrthoSlicer 

 
•  Shows only data intersecting that 

plane 

•  Can be moved within the dataset 
 
•  “Extended section” adjusts slice 

thickness.  Additional data 
projected onto plane as MIP 

 



Oblique Slicer 

 
•  Shows only data intersecting 

that plane 
 
•  Can be freely moved and 

rotated within the dataset 
(similar to Clipping Plane) 

 
•  “Extended section” adjusts slice 

thickness.  Additional data 
projected onto plane as MIP 

 



Visualization II: 
Export and Animation 



Snapshot 

q  Press the Snapshot Button or Press Ctrl T (Command-T for Mac). 

q  Captures the image in the viewing window of the current view. 

q  Captures any items in the viewing area including scale bars, time codes, or 

measurements. 

q  Saves the image as a TIFF file 

q  Works in all Imaris views and in full screen mode (must use Crtl T) 

 



Snapshot 

q  The checkbox “Crop to fill whole snapshot area”. If 
checked, the image will be scaled and positioned 
in the snapshot so that the whole area of the 
snapshot is covered by the image. Parts of the 
image will then be cropped. 

q  “100% Snapshot” when clicked, the snapshot 
width and height will be set to sizes so that the 
zoom in the resulting snapshot will be 100% (1.0), 
i.e. one snapshot pixel will correspond to one 
dataset voxel 

  
 



Snapshot 

q  The size of the resulting snapshot image can be 
selected from a predefined list of dimensions (even 
much larger than the screen size) 

q  You can manually enter the size you would like for 
the resulting snapshot 

q  You can choose the DPI of the resulting image 

 

q  The size of the resulting snapshot  image can be 
the same as the window size of Imaris by clicking 
“Snapshot size from window size” 

  
 



Snapshot 

•  Automatic naming takes the data set name and adds a 
running number for the snapshot name 

 
•  Must choose [...] where you want the Image Output to go 

or nothing will happen 
–  Save to  File 
–  Copy to Clipboard 
–  Combination of both 

 
•  After determining save location, remember to click 

  Do Snapshot! 

  
 



Key Frame Animator 

•  Subsystem to generate movies for animated presentation 
•  Define some key frames 
•  Key frames are views and time points through which the movie must pass. 
•  Store Key Frames 

–  Camera (position, angle, zoom) 
–  Time point of data set 
–  Clipping Planes (position, angle) 
–  Orthogonal Slices (position) 
–  Oblique Slices (position, angle) 
–  Objects Show/Hide 
–  Objects Colors 
–  Display Adjustments 



How to get to Animations 

q  To get to the 
animator, simply click 
on the Animation Icon 
on the top panel. 

q  This is essentially the 
Surpass view with 
the animation toolbar 
at the bottom of the 
screen 



Your Tools : Key Frame Animation 

q  Key Frame Panel –  where your key frames are added and modified 

q  Rotations Panel –  where Automatic and Custom rotations are inserted 
q  Animation Panel – where frames and play state are determined 

q  Play Back State Panel – where you determine what is allowed to appear 
in your animation 

q  Film Strip Panel – where you can see the visual representation of your 
key frames in a film strip 



Your Tools: Key Frame Panel 
q  Click Add and the image present on your main screen will appear as a key frame 

(highlighted in light blue on the film strip) 

q  To modify a key frame highlight the frame in the film strip and adjust the frame to your 
modified version, then click the Mod. button. 

q  The rotation’s pull-down menu will allow you to scroll through the pre-set rotations 
q  The ‘Custom’ button allow you to insert you own degree of rotation in any direction 
q  In the Animation window you can enter the number of movie Frames 
q  There is the button to open the Animation Settings... 
q  Use the play button to play a preview of the movie - Please note to pause the animation re-

click on play button 
q  Use the record (red dot) button to record the movie. THIS IS NOT A STOP BUTTON!!! 



Your Tools: Film Strip 

q  The Strip window provides a working area to create your animation 

q  The thick light blue line indicates the user-defined key frames 

q  The white line indicates the active/selected frame 

q  The thin blue lines represent the interpolated frames 

q  The spacing between key frames can be adjusted and the animation will 
play faster or slower according to the spacing 

q  Left-Click on a line to display that frame in the Surpass view area 

q  Right-Click on a line to select that frame, without changing the Surpass 
view 



Animation: Workflow to create an animation 

1. Load a data set and compose a Surpass scene 
2. Adjust viewing angle (camera) and time point of data set 
3. Click Add Key Frame 
4. Repeat steps 2 & 3 for any other interesting views 
5. Define the total number of frames (duration of animation) 
6. Press the play button to see a preview 
7. Record animation an store it as a movie 
*  Note: When Add is pressed the first time the same key frame is added to the start 

and the end of the filmstrip . This ensures a smooth rotation back to the 
beginning of the movie. 

 



Animation: Recording the Movie 

q  To save the animation as a movie, click in 
the Animation window on the Record button 
(red dot). Then Save As Movie dialog 
window is displayed on screen. 

q  Animat ions may be saved as AVI, 
QuickTime, or a numbered TIFF Series of 
each frame 

q  The frame rate (the play back speed) of the 
movie can be selected 

q  The compression level can be adjusted. 

q  You can choose to have the movie played 
back or not immediately after recording. 

q  Once the save button is pressed, Imaris will 
begin to play through the movie (this is part 
of the recording process) 

q  A screen shot is taken as each frame is 
played and then tied together as a movie 
once all frames are taken. 

 



Saving Your Work : The Imaris File 

q  The Imaris file (*.ims) contains the image pixel/
voxel data, the Imaris-specific scene data and 
the statistics 

q  Combined Image + Scene saving is activated 
by Default 

q  Imaris files that contain scenes can be opened 
in the free Imaris Scene Viewer 

q  Saving files in version 8.2 is significantly faster 
(up to a factor of 5) than previous versions due 
to multithreaded gzip compression of image 
data. This applies to both Imaris and 
ImarisFileConverter. 



q  To save a created Imaris file that contains both image and scene data on your local storage 
space click on the Export option in the File menu or Export icon Export Save.  

q  Saving in Imaris format (*.ims) is recommended whenever the data set is cropped or the 
parameters changed.  

q  Saving a data set in Imaris file (*.ims) format provides the advantage of a faster loading process 
and the possibility of using thumbnails. In addition, parameters are saved with the images. 

q  You can save the file when you are done or if you want you can stop in the middle and resume 
work later. Simply, choose Export from the File menu and give the file a name you will remember. If 
you then close the file and reopen it at a later time, you can resume work from where you left off. 

q  When the work is done, it is recommended to save the dataset by using 'Store as'. Selecting the 
'Store as' option could take longer time but will give you the smallest file size possible. 

Saving Your Work : The Imaris File 



q  To save an existing data set click Store in the File menu or Store icon on the Main 
toolbar.  

q  Selecting this option stores the image data and (any) created objects within the 
selected Arena Group. The icon overlaying the image is updated to reflect the 
newly created surpass objects. The newly created object is added under Properties 
in the Surpass tab.  

q  Please note: Store functionality is implemented to be performed at maximum speed. 
This functionality overwrites the existing file without warning and only writes 
changed or new data without deleting obsolete ones. As a result, the resulting 
Save file could actually be larger than the original. 

Store Your Work in Arena 



q To store the changes made to the image in a different file whilst maintaining the 
original file click on the Store as option in the File menu or Store as icon. 

q This option enables you to modify the image name and creates a new image item 
within the Arena. The selected group now contains one original image file which 
remains unchanged and the new image file with the additionally segmented object. 
This newly created image item has an overlaid icon indicating the image type and 
segmented surpass objects. Under the Objects tab the newly created object is added.  

q Enter the name for the file to be saved or confirm the suggestion. 

q Select the requested file format and click OK 

Store As – a modified image in Arena 



Free Scene Viewer (up to version 7.7.2) 
Discontinued with Imaris8 

q  Installed and licensed with the Imaris installation (up to version 7.7.2) 
q  Floating licenses have unlimited instances, so you can always view your files, even if the full Imaris 

license is in use 

q  Can be installed for free on any other computer that you like. 

q  Must obtain a license by registering on the Bitplane website by going to Downloads and 
then to the free SceneViewer 

q  http://www.bitplane.com/go/download/free-sceneviewer 
 
 



Free Scene Viewer 

q  It is essentially the Surpass 
viewer of Imaris without any 
of the controls. 

q  It opens Imaris scene files 
only when full dataset file is 
available and is capable of 
displaying any element that 
the scene file contains, 
i n c l u d i n g t h e v o l u m e 
images. 

q  Snapshots may be taken 

q  Existing animations can be 
played back 

q  Ideal for sharing data with colleagues who 
don’t own Imaris 

q   Nice for creating figures for publication 
outside of Imaris 



Exercise 1 

In Surpass mode reproduce the following view with the 
ShibutaniAttCorr.ims dataset and Store As the file in Arena 



Exercise 2 

1.   Create this animation 
from spDSADecon-
crop.ims: 

2.   Export the movie as 
an avi file 



Exercise 3 

1.   Create animation from 
ShibutaniAttCorr.ims 
like this: 

2.   Export the an IMS file 


