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Managing Olympus VS200 Slide Scanner Files in QuPath 
This document will show you how to open, view and manage large format images 

created with the Olympus VS200 whole slide scanner in QuPath 

What is QuPath? 

QuPath (https://qupath.github.io/) is FREE, open-source image processing software based on 
ImageJ/Fiji.  It was designed specifically for processing and analysis of large format images 
(fluorescence or histology) and includes support for large format files such as the Olympus 
VS200 .vsi files.  QuPath was developed and is maintained by Dr. Peter Bankhead and 
colleagues at the University of Edinburgh.  

To Cite the Use of QuPath in Your Manuscript 

Bankhead, P. et al. QuPath: Open source software for digital pathology image analysis. Scientific 
Reports (2017). https://doi.org/10.1038/s41598-017-17204-5 

For Help When Using QuPath 

If you hover the pointer over any button or menu item and a description of the item will pop 
up. There is also documentation and some tutorials written by the QuPath development team 
on their GitHub (https://qupath.readthedocs.io/en/latest/) and a NEUBIAS Academy tutorial 
video from April 2020 on YouTube (https://www.youtube.com/watch?v=4An5n6Y_rRI).     

About Olympus .vsi and overview.vsi files 

There are two kinds of files created during 
Olympus VS200 scans: .vsi files and Overview.vsi 
files.  Depending on how your scan was 
collected, there may be multiple .vsi files per 
overview .vsi file, with the overview.vsi file 
containing a low-resolution image of the entire 
slide plus an image of the slide label, and the 
.vsi(s) containing high resolution image(s) of the 
slide contents.  

In the example to the left there are images from 
two slides.  Tray01_Slide01 has an overview.vsi 
image and three .vsi images (blank, 01_ and 

02_) each representing one piece of tissue from the multi-tissue slide. Tray01_Slide02 has an 
overview.vis and only one .vsi image, meaning it only has one piece of tissue OR that all tissues 
on the slide were scanned into one large, high magnification file. Each of the overview.vsi and 
.vsi files has a corresponding folder with the same name.  The .vsi file and corresponding folder 
MUST be downloaded and kept together, and if you choose to rename, they MUST both be re-

https://qupath.github.io/
https://doi.org/10.1038/s41598-017-17204-5
https://qupath.readthedocs.io/en/latest/
https://www.youtube.com/watch?v=4An5n6Y_rRI
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named with the same name, otherwise important information about the image is lost and the 
.vsi file cannot be opened.     

 

Opening an Olympus .vsi or overview .vsi file 

Find the .vsi file you want and drag and drop onto the 
QuPath icon to open.  

 

You can also drag and drop the .ets file which is 
inside the folder with the same name as the .vsi 
file, but we recommend the .vsi file because it 
connects to the pyramidal files created by the 
scanner and makes for smoother rendering as 
you zoom in and out and pan around the tissue. 

 

 

A menu will pop up asking you to choose the file 
type (fluorescence, type of histology) from a 
pulldown.  QuPath uses the image meta-data to try 
to guess what type of image you have opened, so 
you may not see all the possible choices.  
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Missing Slide Label Data - A Warning Before We Go Too 
Far 

The View -> Show Slide Label menu item DOES NOT WORK 
with .vsi files.  The label image is not embedded in the 
metadata and so is not accessible to this function in 
QuPath.  To see the label that goes with your image, you 
must open the Overview.vsi image of the slide that the 
image came from and select the image of the label from 
the pop-up menu. 

 

 

 

 

 

 

Image Information 

Under the Image tab there is information about the 
image gathered from the .vsi metadata. Particularly 
helpful are the Image name, filepath (URI), and the 
magnification and pixel size of the original scan.  
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When You Open A .vsi File (Default view) 

You will see a scale bar, which can be turned off via View -> Scale Bar, and a slide overview box 
which can be turned on and off via View -> Show Slide Overview.   

 

Information in the lower right hand corner is distance from the origin, defined as the upper left 
hand corner of the image, as well as the intensity of each channel at that pixel and the number 
of current z-plane (if you have opened a z-stack). The slider for moving through z-planes is at 
the top left of the image (where the yellow box is above). 

Hold down the right mouse button to drag the image in the window. Use the mouse wheel to 
zoom in and out on your image. To see the effective 
magnification of your zoom, look above the image just to the left 
of center (in the yellow circle above).  You can double click in this 
box, type in any magnification you want and the viewer will 
zoom to this magnification. 
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Rotating Your Image 

To rotate the image, use View -> Rotate Image.  The 
“Reset” button will return the image to the original 
orientation. 

 

Adjusting Brightness & Contrast and Channel Colors 

To adjust image brightness, use the half shaded circle 
button to the left of the effective magnification 
(zoom) indicator.  If these settings were adjusted by a 
previous piece of software, such as the Olympus 
OlyVIA viewer, QuPath will by default keep the 
settings from that software (including autoscaling).   

Slide the balls on the min and max display sliders or 
the bars to the left and right of the histogram to 
adjust intensity for the selected channel (the one 
highlighted with the blue bar).  If you want to type in 
values, double click on the Min display and Max 
display numbers and type the values in the pop-up 
box. 

“Auto” will autoscale the blue highlighted channel to 
the values QuPath thinks are best, “Reset” will set 
values back to the channel’s full range. 

 

To change the name or display color of a channel, 
double click on the channel name in the 
Brightness & contrast list to open the Channel 
properties box.  

Turn channels on and off by clicking the 
checkboxes next to each channel name. View 
single channels in grayscale by checking the 
“show grayscale” box.   

Check the “keep settings” box to apply the same 
brightness & contrast values to new images that 
you open during the same session (good for 
keeping the display constant across samples for 
accurate visual comparisons). 
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Display More Than One Image at a Time (Multiple Views) 

If you would like to display more than one image at a 
time, right click in the large main image window of 
QuPath (can be done with or without an image open 
already) to open the Multi-view pop-up menu. Then from 
that menu choose Add row or Add column.  Add row will 
add the new viewing window below the current window, 
and add column will add to the right of the current 
window.   

 

Images can be opened in a particular 
window by dragging and dropping the 
file onto the window, or by clicking the 
window to select it (a thin red line will 
appear around the window) and then 
using File -> Open to select the file.  

To close the image in a particular 
window but keep the empty viewer 
open, use right click -> Multi-view -> 
Close viewer.  To remove both the image 
AND the window, use right click -> Multi-
view -> Remove row or Remove column. 

 

Linking Views for Synchronized Panning and Zoom 

For certain multi-views, such as serial sections that have 
been stained with different markers, it can be useful to 
link the views so that the slices move and zoom on the 
same area at the same time.   

To do this, right click in the main image window (on top 
of one of the images) and from the Multi-view pop-up 
menu, first choose Match viewer resolutions. Then 
roughly line up all of the tissues so that their 1x views 
move in the same way.  This will make sure that all 

images are at the same starting zoom factor and starting position. Then use either right click -> 
Multi-view -> Synchronize viewers or the keyboard shortcut Ctrl+Alt+S to sync and un-sync all 
viewer windows.  As you zoom in, you may need to refine the alignment by turning off sync and 
adjusting the position of separate tissues and then turning sync back on.  
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To Save Your Image Workspace in QuPath Serialized Data Format 

If you make changes to your image (annotations, brightness/contrast, changes to colors, 
machine learning classifications, etc.) and want to preserve this information in a way accessible 
to QuPath, use File -> Save or File -> Save As to save your image in the QuPath Serialized Data 
format (.qpdata format).  This will preserve your QuPath workspace for this image and allow 
you to continue annotating, modifying or otherwise working with the image in QuPath.  

This file format is compatible with QuPath ONLY and is good for saving work in progress but not 
necessarily finished products. For file types compatible with other software (.tif, OME .tif, .jpg, 
.png, etc.) see the section on Exporting below. 

 

File –> Export Functions to Use All or Part of Your Image in Another Program 

There are several ways to export data; the best way to export depends on what you want to do 
with that data once it is out of QuPath.  Many export options involve down sampling – please 
see the two sections on considerations when creating down sampled images for quantification 
or for display. 

To Export Raw, 16-bit Grayscale Data for Processing or Quantification (.tif, zipped .tif or OME 
.tif format only) 

To export the ENTIRE image (including ALL z-planes if your image is a z-stack)  

File -> Export Images -> Original pixels will give you a 
.tif stack with each channel as a separate, 16-bit 
grayscale .tif. These multipage .tifs can be opened as 
hyperstacks in ImageJ / Fiji.  If your image is a z-
stack, this will automatically export ALL the slices of 
the stack, there is NO option to choose a single stack 
or a substack.  

Note that this export is NOT a screenshot! It will 
automatically export the ENTIRE image, even if you 
are zoomed in so that your screen shows just a small 
portion.   



Created by Christine Labno 
University of Chicago  
Integrated Light Microscopy Core   

For the export, a down sample factor 
of 1 is no rescaling, the pixels are the 
same size as in the original scan.  
However, for whole tissues and very 
large fields of view this will often 
exceed the maximum allowed size of a 
.tif. QuPath will generate a warning 
and prevent you from creating the file. 

In that case, use the OME .tif choice from the pulldown (being aware that there are limited 
programs which can handle OME.tifs), or down sample the image to make it smaller. Be aware 
that in the case of an OME .tif or a lightly down sampled .tif it may take a significant amount of 
time (several minutes to half an hour in some cases) to generate the .tif file and to open that .tif 
in another program such as ImageJ/Fiji.  A down sampled image or a smaller field of view will 
take less memory and time, but can hamper quantification if done incorrectly (see 
considerations when down sampling for quantification below).   

 

Down sampled images DO come in to ImageJ/Fiji with the correct pixel size. For example, the 
image below was down sampled by a factor of 3, and the pixel size reflects that resizing. This 
means that down sampled images can be opened in ImageJ/Fiji and used to create accurate 
measurements or stamped with accurate scale bars.  
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To export a region from the image, including SINGLE planes of z-stacks 

To export a portion of the image as raw, 16-
bit grayscale data (one .tif per channel), first 
draw a region of interest (ROI) on the image 
using one of the drawing tools. Then use File 
-> Export Images -> Original pixels.   

This method will export only the CURRENT 
PLANE of a z-stack, there is no option to 
export the whole stack or a substack.  

The best way to export a region of the image 
in raw data format and keep the whole stack 
or a substack of the z-planes is to export 
directly to ImageJ/Fiji using the Extensions -
> ImageJ method described below. 

 

To export a region from the image, including ALL planes from z-stacks 

When exporting a region as raw, 16-bit grayscale data, the only way to keep all planes of a z-
stack as part of the dataset is to use the Extensions -> ImageJ -> Send region to ImageJ choice.   

Unfortunately, since this method is not part of the Export menu, it doesn’t give the option to 
save the image as a file, but instead it sends the image directly to ImageJ/Fiji.  Saving can be 
done through ImageJ/Fiji using File ->Save As.   

 

 

 

 

 

To include all the z-slices, check the “All z-slices” box 
at the bottom of the Send region to ImageJ menu.  

If you leave Resolution unit in the default um 
(microns), QuPath will send the image to ImageJ/Fiji 
with that pixel size.  In this example that would be a 
1uM pixel size, compared to the original pixel size of 
0.325uM, or an approximately 3-fold reduction in 
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resolution.  To choose no reduction or to control the fold-reduction rather than a strict pixel 
size, change Resolution unit to pixels (down sampling) with the pulldown.  In this case, a 
Resolution of 1 in the pixels (down sampling) choice would lead to NO down sampling, a pixel 
size of 0.325uM (original size) and a very large file.   

“Include ROI” will send the ROI used to create the region to ImageJ so it can be used there.  It 
does NOT include any other regions drawn on the image, even within the exported ROI.  To 
include other ROIs, check “Include overlay” and any ROIs drawn within the larger ROI will be 
exported to ImageJ/Fiji as an overlay. These ROIs can be managed in ImageJ/Fiji using the 
Image -> overlay menu. 

Leaving “Apply color transforms” unchecked sends the region to ImageJ/Fiji as a 16-bit per 
channel hyperstack with all changes to brightness/contrast and false color made in QuPath 
applied. This is the option I would recommend. Checking the box will convert the region to 32-
bits per channel and if any channels are turned off in the QuPath display those channels will 
NOT be sent to ImageJ/Fiji.  This 32-bit option also seems to have some inconsistent behaviors 
with regards to applying brightness/contrast changes from QuPath – sometimes (when all 
channels are displayed in QuPath) changes are applied and sometimes (when some channels 
are turned off in QuPath) they are not.  

 

Considerations When Creating Down sampled Images for Quantification 

As with exporting whole images, down sampling of regions is necessary for creating 
manageable files.  Note the difference in physical size (both images are displayed at 
approximately 50% of their actual size), file size (187MB vs. 21MB) and pixel size (325nm vs. 
975nm) between a region that is not down sampled (factor = 1) and a region down sampled 3-
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fold (factor = 3).   

When exporting data for quantification (not just for display) pay attention to pixel size.  Pixel 
size should be less than or equal to HALF the size of the smallest feature of interest (Nyquist-
Shannon sampling).  For example, to count nuclei which are 10um in diameter, pixel size should 
be 5um or less to prevent separate objects from being combined into a single pixel.  In the 
example below, no down sampling (factor = 1, pixel size 0.325um) or down sampling with a 
factor = 3 (pixel size 0.975um) leaves enough detail that the cell processes in the green channel 
are still distinct, while down sampling with a factor = 6 (pixel size 1.95um) blurs the processes 
and even the cell bodies too much for reliable quantification.  

If your desired pixel size means you cannot down sample enough to create a manageable file, 
consider exporting smaller areas and possibly using multiple regions to get a representative 
sample. 
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To Export RGB Color Images for Display in Presentations and Publications (.jpg, .png, .tif, 
zipped .tif or OME .tif format) 

To export the ENTIRE image (including ALL z-planes if your image is a z-stack)  

File -> Export images -> Rendered RGB (with overlays) 
gives a single, full color RGB file.  

Note that this export is NOT a screenshot! It will 
automatically export the ENTIRE image, even if you are 
zoomed in so that your screen shows just a small 
portion of the image.   

If your image is a z-stack, this will automatically export 
ALL the slices of the stack, there is NO option to choose 
a single stack or a substack with this method.  

Rendered RGB images can be exported in one of five 
possible formats: .jpg (LOSSY compression and NO pixel 

calibration or other metadata, as stated in 
the menu’s text box), .png (lossless 
compression but NO pixel calibration or 
other metadata, as stated in the menu’s text 
box), .tif (uncompressed, keeps pixel 
calibration and other metadata), zipped .tif, 
or OME tif. (large format).  

For the export, a down sample factor of 1 is no rescaling, the pixels are the same size as in the 
original scan.  However, for whole tissues, z-stacks and very large fields of view this will often 
exceed the maximum allowed size of a .tif. 
QuPath will generate a warning and prevent you 
from creating the file. In that case, use the OME 
.tif choice from the pulldown, or down sample 
the image to make it smaller. Be aware that in 
the case of the OME .tif or lightly down sampled 
.tif it may take a significant amount of time 
(several minutes) to generate the .tif file and to open that .tif in another program such as 
ImageJ/Fiji.  A down sampled image or a smaller field of view will take less memory and time 
and is an excellent choice for most presentations and publications (see considerations when 
down sampling for display, below). 
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The “With overlays” part of the name should really say “with annotations” and means that any 
annotations / ROIs drawn on the image will be included automatically.  To exclude the overlays 
in this type of export, delete them under the QuPath Annotations tab before exporting the file.  

Unfortunately, 
the scale bar 
and slide 
overview 
window are 
NOT considered 
overlays and 
are NOT 
included in the 
exported file 
(applies to all 
possible file 
types in the 
pulldown).   

Be aware that 
with a .tif 
export it is 

possible to put a scale bar back on through ImageJ/Fiji because the pixel size data is still 
attached to the file.  With .jpg and .png files this data is LOST and so it is more difficult to put on 
an accurate scale bar  

To export a region from the image, including SINGLE planes of z-stacks 

To export a portion of the image as an RBG color 
image, first draw a region of interest (ROI) on the 
image using one of the drawing tools. Then use 
File -> Export Images -> Rendered RGB.   

This method will export only the CURRENT PLANE 
of a z-stack, there is no option to export the 
whole stack or a substack with this method.  

The best way to export a region of the image and 
keep the whole stack or a substack of the z-
planes is to export directly to ImageJ/Fiji using 
the Extensions -> ImageJ method described in 
the section on exporting raw 16-bit data above. 
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Considerations When Creating Down sampled Images for Display 

When creating images for display, keep in mind that the physical size of the original image is 
likely very large (much larger than your monitor can display at 1:1 scale).  Down sampling is one 
way to get these images to physically fit into a document or presentation without a massive 
amount of rescaling.  It also keeps your document size small.   

Look at the two images below.  Both are the same small region of a much larger brain slice.  The 
one on the left is not down sampled.  It takes 187MB and has been scaled down to 12% of its 
actual size to fit in this document.  The one on the right was down sampled by a factor of 3, 
takes only 21 MB of space and only needs to be scaled down to 33% of its original size to fit 
here.  Notice there is very little difference in visual image quality between the two images, but 
the more down sampled file on the left is easier to work with.  
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To Create Screenshots (Similar to Pannoramic Viewer and CaseViewer Snapshot Function) 

To create a snapshot or screenshot of just the area of the 
tissue currently visible in the QuPath display window, use 
File -> Export Snapshot. 

The only file type available through this choice is .png, 
which is lossless compression, however, if you use this 
export method, know that it is a SCREENSHOT and not a 
true export.  This means two important things: 1) 
metadata are NOT included.  Things like pixel size and 
channel information are LOST and accurate scale bars and 
size measurements are NOT possible from the resulting 
image unless you back calculate the new pixel size by 

multiplying the original pixel size by your down sample factor and apply it to the down sampled 
image in ImageJ/Fiji using Image -> Properties. 

2) The image will appear exactly as rendered in 
the QuPath window at the time of export.  This 
means the size and shape of the QuPath GUI 
window matters and can change depending on 
the monitor you are using or how the window is 
sized to fit a particular monitor.  For example, the 

QuPath GUI was re-sized between the snapshots of the right and left hand 
images, resulting in images with different shapes. 

 

“Main window screenshot” 
and “main window 
content” both create a 
screenshot of the full 
QuPath GUI, including the 
image exactly as sized, 
overview window, scale 
bar, annotations AND the 
full surrounding menus and 
toolbars of the QuPath GUI.    
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“Current viewer content” gives a screenshot of the image 
window with the image exactly as sized, scale bar, overview 
window, annotations, etc. but does NOT include the rest of 
the QuPath GUI.  So much information is lost from these 
types of snapshots that they are only useful for 
presentations or websites, they should not be used for 
publications or for generating data.    

 

 

A Note on OME .tif Export 

File -> Export images -> OME .tiff will create an 
uncompressed, compressed lossless or compressed lossy 
OME .tif with or without a pyramidal file format.  It can 
also create lossless or lossy .jpg 2000 files or lossless LZW 
or ZLIB files. These files can take several minutes to create, 
during which time QuPath may appear to be stuck or not 
responding. Be patient. You will see an onscreen message 
when the export is done. 

Options for opening OME .tifs are limited. Interestingly, 
QuPath will not open OME .tif files that it created, 

throwing exceptions with all OME tif types, so buyer beware on this one.  Native ImageJ/Fiji will 
also not open OME .tif files, but the Big Data Viewer plugin may be capable of opening OME 
.tifs, we have not investigated this possibility as of this writing. 
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Grouping .vsi and overlay.vsi Files with the “Project” Function 

Files can be grouped together using the “Project” functionality.  To create a project, click the 
“Create Project” button and create a new, empty folder with the project name. Once this folder 
is created, click “Add Images” to select the images you want to group together in this project.  
In the case of .vsi files, be sure to add both the .vsi file and the corresponding folder for each 
image you wish to include.  

 


