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ImagedJ and Fiji Citations and Sites

Sites to download ImageJ and related software
ImageJ download site: https://imagej.nih.gov/ij/download.html
Fiji download site: https://imagej.net/Fiji/Downloads

Cell Profiler: http://www.cellprofiler.org/

Icy: http://icy.bioimageanalysis.org/download

MicroManager: http://www.micro-manager.org/

A Note to Fiji Users

In this guide, | mostly refer to ImageJ and Fiji collectively as ImageJ. Most processes
are the same across the two programs and typing ImageJ/Fiji got tiresome and used up
space. If there is something different about or added to a process in Fiji (e.g. updating
on pg. 3 or using a macro on pg. 11) | have highlighted that with a callout to Fiji users.

Citation for the Nature Methods paper on ImageJ

Schneider, CA, Rasband, WS, and Eliceiri KW. (2012) NIH Image to ImageJ: 25 Years
of Image Analysis. Nature Methods 9(7): 671-5.

Places to go for expert help

The ImageJ Mailing List: https://imagej.nih.gov/ij/list.html

The ImageJ Forum: http://forum.imagej.net/

Both the Mailing list and the forum are monitored by a large community of ImageJ users
and developers, including the creator of ImageJ Wayne Rasband and the Fiji
development team, as well as a large number of plugin developers. Questions to the
list and forum are usually answered within a day or two.

One Way to Site ImageJ in Your Manuscript

Rasband, W.S., ImageJ, U. S. National Institutes of Health, Bethesda, Maryland, USA,
http://imagej.nih.gov/ij/, 1997-2012.
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The Command Finder

ImageJ has so many features it can be hard to keep track of all of them. Thankfully
there is a guide to help you find the command you are looking for.

In Fiji version 1.51 and higher,

G e

type your search term in to the File Edit Image Process Analyze Plugins Window Help SCF
white box at the end of the B oz|o|~4m/xAla|o|F] oofsu]w] g 4] |»

taskbar and a new window will Paintbrush Tool
pop up with your search results

scale

1 Quick Search =

¥ | Commands z

‘| Scale Bar...
4 Image > Zoom> Scale to Fit
4 Image> Scale... i| Menu path

4 Edit> Selection Scale... [AnaizEaiions

£2] Image > Adjust> Scale to DPI | 1dentifier

‘é Image > Zoom > Original Scale 7 legacy:ij.plugin.ScaleBar

_é Analyze > Set Scale... b Location

[] imageJ wiki :| IF:IFiji.appljarsfij-1.51s jar

D ImageJ Forum

Source

In ImageJ, The Command Finder can be brought up by pressing the letter L on your
keyboard.

o

Search: [Scale| |

Command Menu Path Class File

Add Scale Bar Cookbook=Annotating Images Add_Scale_Bar_(™) D:\Fiji.app\pluginsic...
—’ Microscope Scale Cookbook=Annotating Images Microscope_Scale(™) D:\Fiji.app\pluginsic...

Original Scale Image=Zoom ij.plugin.Zoom("orig™)

Scale Bar... Analyze=Tools ij.plugin.ScaleBar

Scale to DPI Image=Adjust Javascript Refresh_Javascript_Scripts("D:\Fij...

Scale to Fit Image=Zoom ij.plugin.Zoom("scale”)

Scale... Image ij.plugin.Scaler

Scale... Edit=Selection ij.plugin.RoiScaler

Set Scale... Analyze ij.plugin filter.ScaleDialog

TransformJ Scale Plugins>=Transform=TransformJ TJ_Scale D:\Fiji.app\plugins\...

[] Close window after running command

| Run ” Source ” Close |

For both Fiji and ImageJ, type the name of the command you are searching for in the
Search box and ImageJ will list all of the commands with similar names. In this
example, | was searching for the command to add a scale bar. The name of the
command is in the far left column, followed by the menu path if you would like to run the
command manually. You can also choose to highlight the command and then hit the
“Run” button at the bottom of the screen to run the command.
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The Information at the Top of your Image
1

This information is also found

[Tvbonsr loixd| | - -

24/57; 684.93x684.93 um (256x256); RGB; 14MB Ih our ImageJ BaS|cs_ tutorial, but
A A it is important (especially the

2 highlighted section) so it bears

repeating.

1) The top line contains the name
of the image. This is the “flybrain”
sample image from the ImageJ
library.

2) On the next line, you will see
“24/57”. This means we are
currently looking at slice 24 of a
total of 57 slices in this stack. If
we had a hyperstack (see pg.
28), there would be numbers for
the color channel, z-slice and/or
time point, depending on the

information in our stack. If we
had an image that was a single slice, these numbers would be missing and the
information would start with image size.

3) “684.93um x 684.93um” is the actual image size, or you can think of it as the size of
the field of view. The units on this value depend on how the image is calibrated (see
our ImageJ Basics tutorial pg. 19). In this case, the units are microns. When you make
measurements that involve physical size (area, length, integrated density) the units on
that value are THESE units. If the image is NOT calibrated, the units here and in your
data table will be pixels.

4) “(256x256)” is the image size in pixels. This number is always in parentheses and
always has units in pixels, whether the image is calibrated or not. If the image is not
calibrated, these numbers and the numbers before (#3) will match.

5) “RGB” is the image type. This image is an RGB color image. It is a composite of
three 8-bit grayscale images, one for red, one for green and one for blue. Images can
also be 8-, 12-, 16- or 32-bit grayscale. Note: if you have a 12-bit grayscale image,
ImageJ will list it as a 16-bit grayscale image. | do not know why this happens.

6) “14MB” is the amount of memory your image takes up on your hard drive. You will
notice that .tifs take up more memory than compressed file types like .jpgs and .gifs.
Ltifs are large, but they are the best file type for preserving your data, as they are non-
lossy. They do not throw away any information from your image. With compressed file
types, data is lost during the compression.
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Set Measurements

¢ Set Measurements W Most of this tutorial is about getting
guantitative data from your images. This is not

. » M g an exhaustive tutorial on all the different kinds of

| asideeaionl Modicin e i data that can be obtained from ImageJ, that

I~ Min & max grayvalue [~ Centroid would take a book (or several)!

[~ Center of mass [~ Perimeter

[~ Bounding rectangle [~ Fitellipse Mainly we will be looking at different ways to get

[~ Shape descriptors |~ Feret's diameter data using the built in Analyze - Measure and

[~ Integrated density [ Median Analyze - Analyze Particles commands. This

W e I iifiosis satisfies many of the common requests for

[ e facion I Stack posftion quantitative information that we get.

Before using these commands, go to Analyze ->
Set Measurements and choose the data you
want listed in your data table.

v Limitto threshold | Display label
™ Invert Y coordinates | Scientific notation
|~ Add to overlay

Redirectto: |None ™

MNone
icopy of original image tif

Decimal places (0-9):

oK | cancel | Heip |

The choices in the top portion of the “Set Measurements” window are described on the
ImageJ Documentation page. Some of the more commonly used measurements are:

Area — The area of the selection in pixels or in units squared if the image is calibrated
with Image - Properties or Analyze - Set Scale.

Mean Gray Value —The sum of the gray values of all the pixels in the selection divided
by the number of pixels.

Centroid — The center point of the selection determined by averaging the X and Y
coordiates of all the pixels in the selection. Given in X and Y coordiates (does not work
in 3D). Center of mass is a brightness weighted version of centroid, with coordinates
listed under XM and YM.

Feret’'s Diameter — The longest distance between any two points on a selection
boundary. Choosing this option also gets you the smallest distance between any two
points (MinFeret) as well as the Feret Angle and the X and Y coordinates of the starting
point of the Feret diameter (FeretX and FeretY).

Integrated density — The product of the area and the mean gray value or the sum of all
the pixel intensities in the selection. Often used to analyze dot blots.
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Intensity Analysis

Hover and Read out Gray Levels Pixel by Pixel

There are many ways to read out the
intensity information in an image or image
stack. One of the easiest is to hover over

an area of the image and view the readout 5 sie 1.6t (50%) Coke

of the gray level pixel-by-pixel on the
ImageJ toolbar.

This method is useful for determining
signal to noise in an image, estimating the
gray value of your “background” pixels or
other quick estimates of intensity.

There are other methods better suited
to measuring gray levels across an image
or object.

Plot Profile

To plot the pixel intensities along a line,
first draw a line on you image. Then
choose Analyze - Plot Profile (keyboard
shortcut Control + K).

Gray Value
>
S

=)
S

50

0 50 100 150

Distance (pixels)
:'I:lsvfé Save.. | Copy.. | Live

To get a list of all the values in the plot,
hit the “List” button at the bottom of the plot
window. This list can be saved as an
Excel compatible data table.
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File Edit Image Process Analyze Plugins Window Help

olojz|o|l«|4 A AR OIO] | |6]&]alal

[

x=554, y=260, value=36

1024x1024 pixels; &-bit, TME

File Edit Image Process Analyze Plugins Window Help

glolzlo| 4«8 ARoO | |¢]alala] | |»]
x=554, y=260, value=36
{2 Grn Slide 1.tif (50%) BE=X]

1024x1024 pixels; 8-bit, TMB




Using the Measure Tool with a Drawn Area

409.60x409.60 pm (1024x1024),; 8-hit, 1MB

Analyze - Measure will give you
statistics on the WHOLE IMAGE,
including all the 0 and low intensity
pixels around your object of interest.

Unless your object covers the
entire area of the image, you are
probably going to want to limit your
measurements somehow.

Drawing an area around or within
an object with a draw tool is one way
to do this. Then Analyze ->
Measure will only consider what’s L Results
|nS|de the boundary_ File Edit Font Results

[Area [Mean |

1 167772.160 2.034

“Mean” = mean gray IeveI 2 52089.760 6.504
“Area” is in um”2

1) Whole image
2) Within the yellow boundary line <

If you would like to draw and measure more than one or two areas on a given image,
consider storing your regions by adding them to the ROI manager (pg. 17).
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Using the Measure Tool with a Threshold

A threshold is another way to limit your measured area. Instead of a physical limit,
like a line, this is an intensity limit. The threshold will only consider pixels with gray
values within limits that you set.

To limit your measured area using an intensity threshold:

1) Go to Analyze - Set Measurements and check “Limit to Threshold”. While you're
here, consider checking “Display label” to have the name of your image listed in the
Results window along with your measurements.

2) Use the Image > Adjust - Threshold tool to highlight the area(s) you wish to
measure. You can either use the sliders or use the “Set” button to type in values. Set is
useful when you want to quickly threshold a number of images using the same values.

3) Choose Analyze > Measure. If you keep your “Results” window open between
measurements, you can add as many measurements from as many images as you
want. This table can be saved as an Excel compatible table by choosing file > Save As
from the menu on the Results window (NOT the main ImageJ window).

1024x1024); 8-hit; 1MB

Iv Area IV Mean gray value
[~ Standard deviation |~ Modal gray value
™ Min & max grayvalue [ Centroid

Default <! [Red <] I~ Center of mass I~ Perimeter
I~ Bounding rectangle | Fitellipse

[V Dark background [~ Stack histogram

Auto | Apply

[” Shape descriptors [~ Feret's diameter
[ Integrated density ™ Median

I~ Skewness I Kurtosis

[ Area fraction [~ Stack position

[v Limitto threshold |~ Display label
I InvertY coordinates [~ Scientific notation
[~ Add to overlay

Redirectto: |None ;

Decimal places (0-9):. 3

OK Cancel | Help

File Edit Font Results
Area [Mean | >
1 167772.160 2.034
2 52089.760 6.504
3 23552 13.834

“‘Mean” = mean gray level
Area is in um”2

1) Whole image

2) Yellow area from pg. 3
3) Thresholded area

Information about the other
options in this window can be
found on the ImageJ website
under Documentation, Menu
Commands
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Creating a Binary Image

What if we wanted to count the number of objects in an image, or know the mean
gray value or area of each of those objects? We can use the Analyze Particles function
to do both of these things.

In this example, we are starting with a single
channel, grayscale image.

1) If you just want an object count, or if the statistics
you want for each particle (see pg. 5 for the list of
possible stats) does not involve intensity (e.g. area,
Feret’'s diameter) continue to step 2. If the statistics
you want DO involve intensity information (e.g. mean
gray value, integrated density) or you’re not sure, first
make a copy using Image > Duplicate or Cntl + Shift +
D before continuing to the threshold step.

2) Use Image - Adjust = Threshold to highlight the objects to count and / or measure.
A thresholded image is shown below.

The Threshold Tool

£
0.04x0.04 cm (512x512); 16-bit; 512K

{ Threshold MEX 3) In order to use the

Analyze Particles
feature, the image must
be binary (contain only
values that are 0 or
255).

< | 1521

< >| 9020
Default v | |Red v|
rk background |~ Stack histogram

ui, To make this image
N’

binary, either use the
“‘Apply” button on the
“Threshold” window with
“Dark background”
checked, or choose
Process - Binary >
Make Binary.
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d

The Watershed Tool

0.04x0.04 e (512x51ﬁ);8-bn (inverﬁng LUT), 256K 4) Thisis a binary image. The pixel
2T 5 e b o W e P LT . e ] valuesin this image are either 0
» ‘. *» By S s 2. @ ey - “ S & .
B -_2" ST Na, e Sete e A (white) or 255 (black). Analyze
“f 4 . a5 T . . .
by 22000 30 o0 - b " h Particles will only see this type of
a image.

5) Holes in objects like this one can
be filled with the Process - Binary
—> Fill Holes tool.

6) Before we count, notice that there
are some areas where two or more

objects are touching. We can use the
Process - Binary - Watershed tool

0.04x0.04 cm (51 2¢612); 8-hit (inverting LUT;,; 2661

:," a* et o f“.‘ ._: L g P
- r ’.\. 2 4 8. .v:‘-‘.. &~ .'.,

g ..z - ¥ .“"‘ .. . o..’. ;..‘ 3 "

e e iy L 8 .
" e .‘-;o..o’i." "8 8¢ o'y, ' e .
., LE T T L .. L .o BE &
: ‘. M TR A v T
» ,‘ + [ .i.. " f‘,- . ._1_:, -3
s % r @ B - e & Feo g
> - 4 s, @ ‘i .
& L » : *» :‘. By D20 . B¢ " 5 %
¢ .f" A S R I A
[ e Tet W o L = e ™ nog? &
g1 ..‘ o T g% ;% . " Seabr. 4
- eige. P - * 9 "o

T ow ] - 'ﬁ“ R ..-;‘!."1 W .”l-
WO T -4+ A U ol
bl T o s Y 85" = ' . o
o arvy W mF a2 8T L Nt

L 3] . ot -

2 :“‘, . '.. ."g "“c‘.‘ 005" Aol TS
‘- 4. ..‘ & *... ‘_‘ -y’ " - *;P <
- ’-t':. - . - L

A P P T & "8
Fae W Q-.'." e . o
+ ¥ e " h ...o; «® ' Iy
e g"‘ t te ® -
-8 o saf nf T et »
3..... - o te §7.

L bt PO a'r o

e = ME pC SR Bk
S
" a0 "':c- T dave, \

Here is the image before (left) and after (right) the Watershed tool. Notice that most
touching objects were cut at places where the diameter of the object changed. Some
objects were cut perfectly, some were cut unnecessarily and some touching objects
were missed. This is typical of the watershed tool. Different thresholds could give
different results, so some experimentation with the Threshold and Fill Holes tools may
be necessary to get the best results.
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Redirecting to another image for gray values

~

-

¢ Set Measurements

IV Area ¥ Mean gray value
[~ Standard deviation |~ Modal gray value
[~ Min & max grayvalue |~ Centroid

I~ Center of mass [~ Perimeter

I~ Bounding rectangle [~ Fitellipse

I” Shape descriptors | Feret's diameter
[~ Integrated density [~ Median

I~ Skewness I™ Kurtosis

[ Area fraction |~ Stack position

V¥ Limitto threshold | Display label
[~ Invert Y coordinates | Scientific notation
[~ Add to overlay

Redirectto: |None

None
.copy of original image tif

Decimal places {0-9):

oK | cancel | Heip |

7) At this point, if you choose any of the
measurements that involve gray values, such
as “Mean gray value” or “Integrated density,” go
back to the “Set Measurements” window under
Analyze - Set Measurements.

Use the Redirect to: pulldown at the bottom of
the “Set Measurements” window to redirect to
the copy of your original image (whatever its
name may be). The image must be open in
ImageJ to appear in the pulldown. If you don’t
redirect, all of your values will be taken from the
binary image, so they will be either 0 or 255, not
the true values!

8) Once you have chosen the statistics you want, created a binary image and, if
necessary, redirected to a copy of the original image for gray values, you are ready to
choose Analyze - Analyze Particles. The next few pages will walk you through the

Analyze Particles menu.
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Analyze Particles

Analyze = Analyze Particles has lots of features that allow for fine tuning of object
detection and documentation of counts. We will walk though each of these features in
the next few slides.

The Help, Documentation, Menu Commands section on the ImageJ website also
provides information on these features.

409.60x409.60 g (51 2x512), 8-hit (inverting LUT); 2561
-

.+ fua E ] -
‘-'3; st .'.* P B -
PP T I L bl iy e "M ey *2Fe g
- Conep y .'I"; s ..* l"'."' .. - .C*" :‘a l.‘ . ®
¢ Analyze Particles ; . =3 .~ : * -..:‘.. L I ‘“ &
- a Cad
.E-.- ...‘- AE & o ':.‘ ..f' N B
O-Infinity — e f-- * e e P » = g
G Tl 4 a ® - - =
I Pixel units 4% . ._. @ ‘ ‘- * ";";"0.' L
o > r @ i I av & Y0 &
Circularity; | 0.00-1.00 - =
ircularity ® » ..f.: :: :.: .‘ ® "0, '.. , } *® -]
Show: | Nothing " . @ . e'pg 0% ."‘:. e ¢ ‘,v ® 'i't‘.‘,
& ‘\'.'. ‘.. " L . _,“ = .. " . - ‘:‘ﬂ.‘ﬁ‘
[ Display results I Exclude on edges 5 ® = .':“.‘,- "‘fﬂ"!‘ ‘." > ﬁ'” ' l"}
[~ Clear results I Include holes hd - - * “Q !l: L e w’-' Y : . ﬁ_.’
o Fr} E 3 4 :
50 I~ Record starts oa? & R & ¥ ¥ ¥ .’ * = . 1
- =S W, e Y wmFlie, » 8 v Tugl, pt
[~ AddtoManager I In situ Show ® iat‘." o ¢ e, . & F u
s % L0 mE gt e ot T%
oK J Canu:el‘ HeIpJ ‘4% e **- Oy, W "l-.!. d
¥ - ' oy i bt i L
» & Pl ".t. = » -
sk e Py R SO
. eaie GMe. T g ’
e Can: «..,.,‘ -
»? Ll Y C’ g ¢ ® ' .? ¢ .
e 0 a’i;t't * - -
pa., '-. v Bal .‘ . .‘ [ ] .. ‘ "
": .. L | o & 01 = w o - ‘.. ...
fe & et e 7
L/ i
"% 9" s \
s, 0,0 Be7 0, ¢ Havy,

The first feature in the “Analyze Particles” window is a size threshold. The default (O-
Infinity) is to include all objects no matter how large or small they are.

However, in this image, all of the nuclei should be roughly the same size. Other,
smaller objects in the image are likely debris. If nuclei are approximately 100um”2 in
size, a range of 80-120um would likely count all of the nuclei while excluding objects
that are too large or too small to be considered.

IMPORTANT — check the units on your size threshold (circled above)! If you have
not calibrated your image under Image - Properties, these units may not be correct
and your size cutoff will be inaccurate.

Checking the “Pixel units” box will cause the size threshold to ignore the units of
scale and exclude objects based on how many pixels they contain. This is a good way
to exclude single pixel noise spots from being counted as objects.
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¢ Analyze Particles

Size (pm*2): | 0-nfinity
[ Pixel units

Circularity: | 0.00-1.00

'Nothing

[ Display results

|

I Exclude on edges

I Include holes

- Ri II II starts

OK J Canu:el‘ HeIpJ

[ Clear results
i ;
[ Addto Manager

] * ae
‘e o 4

by, -
iy}
we®
-

*e
.
e 8 B¢ ae,
es e’ g .
L)
o
-
S -

F

r

? .

\

The second feature is a circularity threshold. The default (0.00-1.00) is to include all
objects no matter how round they are. 0.00 is a straight line, 1.00 is a perfect circle.
Most natural objects fall somewhere along this continuum, and often using the default
full range is the best way to go. Some experimentation with size and circularity

thresholds may be necessary.

The “Show” feature of the box makes that type

0.04x0.04 cm (512x512); 8-bit (inverting LUT); 256K
e

1 H 1 - v ¢ & Drawing of nuclei counter demo blue image.ti s ==
of experimentation easier. . . T @;nf = %@:JEJ
... ww )3 o 3 7z 5 ]
« ' . . . :, P @gg 2;@ 3 9‘,@@73?@&3@%
The “Show” feature gives an image marking 2o ;3 B w6
H “ H ” 3 191 @
all of the counted / analyzed objects. “Outlines * e ' o
. . “4 Boes 19 o) w1 i
(shown at right) creates a new image, draws the o m, =" Cloy 00 25
outline of the particle, and gives each particle a . @%@ N ’ :
unique number that corresponds to the object’s o
. - W
number in the data table. o - :
P o P
(I S @ 0 Oy
. . . e «
Other menu choices are described (with %) @@%@ﬁ@ s
pictures) under Documentation - Menu i %@@ B @,-
Commands on the ImageJ website. 1P o T
. « . ” ¥ RS ol 2
IMPORTANT -- Checking “In situ Show T
writes the_outlln_es /masks /particles dlre_ctly T
onto the binary image, rather than creating a larea |Mean |
new window. DO NOT use this if you plan to  |418 0640 255
re-do your analysis with new parameters! wit) BB 2on
420 264 .320 285
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“Exclude on edges” and “Include holes” are also used to exclude particles from
analysis.

409 A0x408 B0 prn (512661 2 8-hit Grverting LUTY: 256K
— - - o= w
s a @ of‘""."‘li'oq'ﬁ" £
* Ty B A& & - v, -
) :

: - » fe. L ¥ 2 = . W
¢ Analyze Particles i *" .o‘, bl ¢ o a @ *d ®

[ ]
Size (ume2): | O-Infinity *Tag oF 0

* 4
[ Pixel units >
e e
Circularity: | 0.00-1.00 z

Show: | Nathing » . @ i L
-

[ Display results I Exclude on edges
L Include holes

[ ReTom™

[ Clear results
[

dIs

[ AddtoManager [ Insitu Show

OK ‘ Cancel‘ Help‘ 'rl'. u

Checking “Exclude on edges” will exclude any patrticle touching the frame of the
image from being counted / analyzed.

Enabling “Include holes” will NOT count objects enclosed within other objects and
will measure objects with inclusions as though they were solid (without inclusions).

Created by Christine Labno
University of Chicago

Integrated Light Microscopy Core
Page 14 of 22




The rest of the “Analyze Particles” box deals with data and region of interest (ROI)
management.

“Display results” will create a data table listing all of the objects in the image with the
statistics you chose under Analyze - Set Measurements for each object.

408 B0K408 60 M (512461 2): &-bit Grverting LUTY 256K
ag ™ > v w v Y G ] L
:-"‘ ..‘ ... 'y f}. .-.' e =3 “ 9™ . “-'~
> My, B R 8. '_. v, - N
< ~5 ® we® e % ".. 2
oo e B Ay

7 & vy B o = I
¢ Analyze Particles - - %0 .' : P :,.. » ., “d L
& ofe 0 .-.‘ 4.."-' » 'ﬂ, i 2
oEe ] .. "9 * o &
- - s " '.. [ - - -

-

L J
Size (pm*2); | O-Infinity e 0

I Pixel units

Circularity; | 0.00-1.00

Show: |Nothing ~

I Display results [ Exclude on edges
=

Clear results I Include holes

: [~ Record starts
I AddtoManager [ In situ Show

Ok I CanceIJ Help]

- ¢ Results [g@
File Edit Font Results
|Area |Mean | g

418 0840 255
419 60160 235
420 264320 255
421 3200 235
422 12160 255

<] A >

This is a partial data table for the image above. Notice that all of the mean gray
levels listed are 255. This is because Set Measurements was not set to “redirect” to the
original, non-binary copy of the image!

If you find yourself in this situation, start back at the beginning. Create a copy of the
image with Image - Duplicate, then use the threshold tool to make your copy into a
binary image (pg. 9). Set up your redirect to the original (pg. 11), click back on the
binary image and run Analyze - Analyze Particles again with “Clear results” checked
so you delete all of the previous results out of the table and restart the particle
numbering from 1. Leaving “Clear results” unchecked will add the results of the current
analysis to any existing data in the “Results” table. Particle numbering will start from the
last number in the previous dataset (423 in this example).
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“‘Summarize” will give a separate data table listing the name of the image being
analyzed, the TOTAL object count and the MEAN value for all other statistics.

¢ Summary M=% The “Summary” window can also
File Edit Font | be left open through several rounds
: T _ : .

Slice [Count [Tatal Area_|Average *| o1 images worth of analysis to build

nuclei counter demo blue image tif 753 28785607 34018 :
_ ek a dataset. This table shows the
nuclei counter demo blue image tif - 703 25733607 36375

nuclei counter demao blue image it 564 25086.086 44.479 results of four rounds of analySIS on

nuclel counter demo blue image tf 24 3575041 14poe0 | e image above, with particle size
cutoffs of 2, 10 and 100 um”2.

“Add to Manager” will add outlines of all of the particles to the ROI (Region of Interest)
Manager.
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The ROI manager holds the shape and position of each region and can be used to
transfer regions created on one image to make measurements in the same area on one
or more other images.
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¢ ROl Manager

l=Joles
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Properties...
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More »
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This is the ROl Manager

You can get to this tool
either by opening Analyze -
Tools - ROI Manager and
adding regions by hand, or by
checking the “Add to Manager”
box in the Analyze Particles
Window and automatically
adding all ROls to the Manager.

Notice each region is
individually numbered, both in
the manager and on the binary
image.

Unchecking “show all” will allow you to see one region at a time, for easier viewing.

Unchecking “labels” will turn off the numbering on the image.

If we click on the original image and
then on one of the region names in the
ROI manager list, we can restore the
region to the original image (blue
outline shown at right).

Multiple regions can be selected by
holding down the “shift” or “control”
keys.

Hitting the “Measure” button in the
ROI Manager window will measure the
region(s) selected, giving you a
Results table with all the

¢ restore selection.jpg (25%) Q@

1024x1024 pixels; 8-bit;, 1MB

¢
10185-0449 ~ Add m
0186-0448 I

0187-0455 Update
0188-0460 Delete
0189-0451 ]
0190-0457 'm
0191-0475 Measure
|0192-0459

0193-0463 | Deselect
IS0 Properties...
0195-0465 _
0196-0468 Flatten [F]
0197-0474 |
0198-0470 |_Moto»
|0199-0469 [V Show All
e v abeis

measurements you selected under Analyze - Set Measurements. “Delete” will remove
an ROI from the list, “Update” will save any changes (movement, resize) done by hand
to an ROI. “Add” or keyboard shortcut “t” will add a hand-drawn region to the list.

Created by Christine Labno
University of Chicago

Integrated Light Microscopy Core
Page 17 of 22




&

1024x1024 pixels; 8-hit; 1MB

Created by Christine Labno
University of Chicago

Integrated Light Microscopy Core
Page 18 of 22

£ ROl Manager B@
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The “More” button at the
bottom of the list will give
even more tools.

The “Multi Measure” option
is particularly useful, it will
give whatever
measurements you
selected under the Analyze
- Set Measurements
menu for all regions in the
ROI manager. Regions do
not have to be highlighted
(selected) to be measured.

“Save” will allow you to
save your list of ROIs for
future use. The list gets
saved in a zipped folder.
To reuse, open the “Open”
Analyze - Tools - ROI
manager and go to More
- Open. Choose the
zipped folder with your ROI
setin it and the regions will
appear back in the list.




Transferring Regions
Restore Selection

The Redirect and ROl Manager features are good ways for generating a lot of
regions (e.g. outlines of nuclei) and then using those regions to get information from
multiple images (e.g. multiple color channels, to determine something like how many
nuclei are red, how many are green and how many are both).

But what if we wanted to know how many small particles were inside a larger object?
For example, in the image below, we have one channel representing a pancreatic islet
(green, left) and one channel representing nuclei (blue, right). What if we need to know
how many nuclei were in the islet vs. in the whole image?

10241024 pixels;, RGB; 4MB

10241024 pixels; RGB; 4MB

Edit = Selection > Restore Selection (keyboard shortcut Ctrl + Shift + E) can be
used to copy any object drawn on one image to other images of the same size. The
region/line/arrow will be copied with the same xy position and size.

Regions can be moved or resized once they are transferred to the new image. In this
example, the islet in the green image was circled using the oval draw tool. Then the
DAPI blue image was selected and the selection was restored with the Restore
Selection command. The “clear outside” tool could be used to eliminate non-islet nuclei
from an object count.

Restore selection is also useful for cropping multiple images to the same size and
shape for figure creation. You can use Edit - Selection > Specify if you need to draw
an object with a defined size.
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Creating and Transferring a Selection with a Threshold

Drawn regions have their place, but often an image has objects with irregular
shapes, multiple objects, or we have a dataset with too many images to hand-draw
regions. In these cases, a more exact way to transfer the location of regions is to create
a mask. Using the green islet image from the previous example, first use Image »>
Adjust - Threshold to threshold the object(s) to be outlined. Remember threshold only
works on grayscale images, which is why this image was converted from RGB color to
8-bit gray.

< .
1024x1024 pixels; 8-bit; 1MB 10241024 pixels; 8-bit; 1MB

Threshold

1024x1024 pixels; 8-hit, 1MB

Original Image Create selection

Once the object is thresholded, use Edit - Selection :
- Create Selection to outline the thresholded area.
Finally, click the image you want to transfer the region Restore selection.on
to and use Edit - Selection = Restore Selection to CongSpongINginmge
create the region on the new image(s).

Let’'s say we now wanted to count the number of
nuclei and know the average pixel intensity of each
nucleus inside the region defined by the islet (nuclei
inside the yellow border (right).

1) Once you have restored your outline onto the
nuclei image, use Edit - Clear Outside to remove
nuclei outside the region of interest.

2) Create a copy of the cleared image and threshold / apply the remaining nuclei to
create a binary mask image (pg. 11).

3) Redirect to the non-binary copy under Analyze - Set Measurements (pg. 5).

4) Click on the cleared, binary copy of the nuclei image. Use Analyze - Analyze
Particles to get statistics for all nuclei in your image (pg. 12).
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Installing and Using Toolsets

Toolsets are another type of addition for ImageJ. They add on to the functions of the
main task bar, and are written like macro code but installed in a way that is similar to
installing a plug-in. We will see two different toolsets in this tutorial which enhance skills
that we have from the Basics and Intermediate classes, but there are other toolsets out
there. Remember, all Imaged resources are free to anyone, so don’t be afraid to
download new tools and explore their functions!

BioVoxxel _Toolbox

The BioVoxxel Toolbox was developed by Dr. Jan Brocher, a member of the
ImageJ/Fiji community with extensive experience in collecting and processing images.

His Toolbox is available (with descriptions of the functions) on the Fiji site:
http://fiji.sc/BioVoxxel Toolbox or without descriptions from his own site at
http://www.biovoxxel.de/macros.html. Either way, to install, right click on the link and
choose the “Save link as” option, saving the link into your ImageJ - Macros - Toolsets
folder.

If you are using Fiji, you can set up automatic updates for the BioVoxxel _Toolbox
under Help - Update Fiji. Click the “Manage Update sites” button (after the
Checksummer) and check the box next to “BioVoxxel.”

Once installed, click the More Tools Icon (the red double arrow) on the taskbar

|1y (Fiji Is Just) Imagel
File Edit Image Process Analyze Plugins Window Help Cookbook

Box|o| <4« [nAla|o|l] xfswjw|s|s]a] |» StartupMacros*

"More Tools"” menu (switch toolsets or add tools)
BioVoxxel_Toolbox

Clear Custom Tools
Drawing Tools
Lookup Tables
Magic_Montage
Nearest_Neighbor_Indicator

-loix]

File Edit Image Process Analyze Plugins Window Help Cookbook
[=Reli=ilo/EPAR SANPNEN v AL PAPAT 4

BioVoxxel Macros Menu

Selecting the
BioVoxxel Taskbar will add a
new icon to your taskbar. The
Bio_Voxxel icon is a green
cube with a red arrow. Click

Advanced Particle Analyzer
Field-of-view measure correction

Shape Descriptor Maps
Binary Feature Extractor

.. Speckle Inspector
this icon to see the Toolbox
dropdown menu. EDM Erode
EDM Dilate
Auto Binary Masking

My two favorite tools are
Watershed Irregular Features,
which allows tuning of the watershed function for better separation of non-round objects,
and the Threshold Check, which allows you to try all of the autothresholds at once and
can help with choosing a suitable autothreshold function. Click the Fiji link above for
more documentation on these tools and all others in the Toolbox.
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Magic Montage

Magic Montage was created by Jerome Mutterer. The code for the Magic Montage
tool can be found on the ImageJ main page at
http://rsbweb.nih.gov/ij/macros/toolsets/Magic%20Montage.txt.

To install, copy/paste the text into a .txt file and save it to your ImageJ - Macros -
Toolsets folder. Once installed, restart ImageJ/Fiji and then click the More Tools Icon
(the red double arrow) on the taskbar and choose “Magic Montage”

[1}! (Fiji Is Just) Image]

File Edit Image Process Analyze Plugins Window
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Select Panels Tool

You will see some additional icons added to your toolbar:

The first icon will create a montage from an RGB image (splitting out one panel per
color channel, similar to the RGB to Montage plugin).

The second button allows you to right click on and manipulate images within the
montage (copy, paste, add images, etc).

The third button allows you to re-arrange panels within the montage, and dragging the
line outside the border of the montage allows you to add panels.

The fourth button allows you to add text (right click on the button to see options).

For more information, there is a great, short video tutorial by Mathieu Erhardt on the
ImageJ / Fiji documentation wiki:

http://imagejdocu.tudor.lu/doku.php?id=video:utilities:creating montages with magic m
ontage
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