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Photoshop provides a variety of effects—such as shadows,
glows, and bevels—that change the appearance of a layer’s
contents in a non-distructive way. Layer effects are linked to
the layer contents. When you move or edit the contents of
the layer, the same effects are applied to the modified
contents. For example, if you apply a drop shadow to a text
layer and then add new text, the shadow is added
automatically to the new text.

A layer style is one or more effects applied to a layer or layer
group. You can apply one of the preset styles provided with
Photoshop or create a custom style using the Layer Style
dialog box. The layer effects icon  appears to the right of
the layer’s name in the Layers panel. You can expand the
style in the Layers panel to view or edit the effects that
compose the style.

You can apply multiple effects in a single layer style. Also,
more than one instance of some effects can comprise a layer
style.

Layers panel showing layer with multiple effects applied

A. Layer effects icon B. Click to expand and show layer
effects C. Layer effects 

When you save a custom style, it becomes a preset style.
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Preset styles appear in the Styles panel and can be applied
to a layer or group with a single click.

Apply preset styles

You can apply preset styles from the Styles panel. The layer
styles that come with Photoshop are grouped into libraries
by function. For example, one library contains styles for
creating web buttons; another library contains styles for
adding effects to text. To access these styles, you need to
load the appropriate library. For information on loading and
saving styles, see Create and manage preset styles.

Note:

You cannot apply layer styles to a background, locked layer, or
group.

Display the Styles panel

Apply a preset style to a layer

Normally, applying a preset style replaces the current layer
style. However, you can add the attributes of a second style
to those of the current style.

Choose Window > Styles.1

Do one of the following:

Click a style in the Styles panel to apply it to the
currently selected layers.

Drag a style from the Styles panel onto a layer in
the Layers panel.

Drag a style from the Styles panel to the
document window, and release the mouse

1
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Apply a style from another layer

In the Layers panel, Alt-drag (Windows) or Option-drag
(Mac OS) the style from a layer’s effect list to copy it to
another layer.

In the Layers panel, click-drag the style from a layer’s
effect list to move it to another layer.

Change how preset styles are displayed

button when the pointer is over the layer
content to which you want to apply the style.

NNoottee: Hold down Shift as you click or drag to add
(rather than replace) the style to any existing
effects on the destination layer.

Choose Layer > Layer Style > Blending Options,
and click the word Styles in the Layer Style
dialog box (top item in the list on the left side of
the dialog box). Click the style you want to apply,
and click OK.

When using a Shape tool or Pen tool in shape
layers mode, select a style from the pop‑up
panel in the options bar before drawing the
shape.

Note:

Some effects have a + icon, indicating that they can
be applied more than once in a layer style.

Click the triangle in the Styles panel, Layer Style
dialog box, or Layer Style pop‑up panel in the
options bar.

1
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Layer Style dialog box overview

You can edit styles applied to a layer or create new styles
using the Layer Style dialog box.

Layer Style dialog box. Click a check box to apply the current
settings without displaying the effect’s options. Click an effect
name to display its options.

You can create custom styles using one or more of the
following effects:

Drop Shadow

Adds a shadow that falls behind the contents on the
layer.

Choose a display option from the panel menu:
Text Only to view the layer styles as a list.

Small Thumbnail or Large Thumbnail to view
the layer styles as thumbnails.

Small List or Large List to view the layer styles as
a list, with a thumbnail of the selected layer style
displayed.

2
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Inner Shadow

Adds a shadow that falls just inside the edges of the
layer’s content, giving the layer a recessed appearance.

Outer Glow and Inner Glow

Add glows that emanate from the outside or inside edges
of the layer’s content.

Bevel and Emboss

Add various combinations of highlights and shadows to a
layer.

Satin

Applies interior shading that creates a satiny finish.

Color, Gradient, and Pattern Overlay

Fills the layer’s content with a color, gradient, or pattern.

Stroke

Outlines the object on the current layer using color, a
gradient, or a pattern. It is particularly useful on hard-
edged shapes such as type.

Apply or edit a custom layer style
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Note:

You cannot apply layer styles to a background layer, a locked
layer, or a group. To apply a layer style to a background layer,
first convert it into a regular layer.

Select a single layer from the Layers panel.1

Do one of the following:

Double-click the layer, outside the layer name or
thumbnail.

Click the Add A Layer Style icon   at the
bottom of the Layers panel and choose an effect
from the list.

Choose an effect from the Layer > Layer Style
submenu.

To edit an existing style, double-click an effect
displayed below the layer name in the Layers
panel. (Click the triangle next to the Add A Layer
Style icon   to display the effects contained in
the style.)

2

Set effect options in the Layer Style dialog box. See
Layer style options.

3

Add other effects to the style, if desired. In the Layer
Style dialog box, click the check box to the left of the
effect name to add the effect without selecting it.

Note:

You can edit multiple effects without closing the
Layer Style dialog box. Click the name of an effect
on the left side of the dialog box to display its

4
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Altitude

Angle

Anti-alias

Change style defaults to custom values

Layer style options

For the Bevel and Emboss effect, sets the height
of the light source. A setting of 0 is equivalent to ground
level, 90 is directly above the layer.

Determines the lighting angle at which the effect is
applied to the layer. You can drag in the document window
to adjust the angle of a Drop Shadow, Inner Shadow, or Satin
effect.

Blends the edge pixels of a contour or gloss

options.

In the Layer Style dialog box, customize settings as
desired.

1

Click Make Default.
When you next open the dialog box, your custom
defaults are automatically applied. If you adjust
settings and want to return to your custom defaults,
click Reset To Default.

Note:

To return to Photoshop’s original defaults, see
Restore preferences to default.

2
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Blend Mode

Choke

Color

Contour

Distance

Depth

Use Global Light

contour. This option is most useful on small shadows with
complicated contours.

Determines how the layer style blends with
the underlying layers, which may or may not include the
active layer. For example, an inner shadow blends with the
active layer because the effect is drawn on top of that layer,
but a drop shadow blends only with the layers beneath the
active layer. In most cases, the default mode for each effect
produces the best results. See Blending modes.

Shrinks the boundaries of the matte of an Inner
Shadow or Inner Glow prior to blurring.

Specifies the color of a shadow, glow, or highlight.
You can click the color box and choose a color.

With solid‑color glows, Contour allows you to
create rings of transparency. With gradient-filled glows,
Contour allows you to create variations in the repetition of
the gradient color and opacity. In beveling and embossing,
Contour allows you to sculpt the ridges, valleys, and bumps
that are shaded in the embossing process. With shadows,
Contour allows you to specify the fade. For more
information, see Modify layer effects with contours.

Specifies the offset distance for a shadow or satin
effect. You can drag in the document window to adjust the
offset distance.

Specifies the depth of a bevel. It also specifies the
depth of a pattern.

This setting allows you to set one
“master” lighting angle that is then available in all the layer
effects that use shading: Drop Shadow, Inner Shadow, and
Bevel and Emboss. In any of these effects, if Use Global Light
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Gloss Contour

Gradient

Highlight or Shadow Mode

Jitter

Layer Knocks Out Drop Shadow

Noise

Opacity

is selected and you set a lighting angle, that angle becomes
the global lighting angle. Any other effect that has Use Global
Light selected automatically inherits the same angle setting.
If Use Global Light is deselected, the lighting angle you set is
“local” and applies only to that effect. You can also set the
global lighting angle by choosing Layer Style > Global Light.

Creates a glossy, metallic appearance. Gloss
Contour is applied after shading a bevel or emboss.

Specifies the gradient of a layer effect. Click the
gradient to display the Gradient Editor, or click the inverted
arrow and choose a gradient from the pop‑up panel. You can
edit a gradient or create a new gradient using the Gradient
Editor. You can edit the color or opacity in the Gradient
Overlay panel the same way you edit them in the Gradient
Editor. For some effects, you can specify additional gradient
options. Reverse flips the orientation of the gradient, Align
With Layer uses the bounding box of the layer to calculate
the gradient fill, and Scale scales the application of the
gradient. You can also move the center of the gradient by
clicking and dragging in the image window. Style specifies
the shape of the gradient.

Specifies the blending mode of
a bevel or emboss highlight or shadow.

Varies the application of a gradient’s color and
opacity.

Controls the drop
shadow’s visibility in a semitransparent layer.

Specifies the number of random elements in the
opacity of a glow or shadow. Enter a value or drag the slider.

Sets the opacity of the layer effect. Enter a value or
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Pattern

Position

Range

Size

Soften

Source

Spread

Style

drag the slider.

Specifies the pattern of a layer effect. Click the
pop‑up panel and choose a pattern. Click the New Preset
button  to create a new preset pattern based on the current
settings. Click Snap To Origin to make the origin of the
pattern the same as the origin of the document (when Link
With Layer is selected), or to place the origin at the upper-
left corner of the layer (if Link With Layer is deselected).
Select Link With Layer if you want the pattern to move along
with the layer as the layer moves. Drag the Scale slider or
enter a value to specify the size of the pattern. Drag a pattern
to position it in the layer; reset the position by using the
Snap To Origin button. The Pattern option is not available if
no patterns are loaded.

Specifies the position of a stroke effect as Outside,
Inside, or Center.

Controls which portion or range of the glow is
targeted for the contour.

Specifies the radius and size of blur or the size of
the shadow.

Blurs the results of shading to reduce unwanted
artifacts.

Specifies the source for an inner glow. Choose
Center to apply a glow that emanates from the center of the
layer’s content, or Edge to apply a glow that emanates from
the inside edges of the layer’s content.

Expands the boundaries of the matte prior to
blurring.

Specifies the style of a bevel: Inner Bevel creates a
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Technique

Texture

bevel on the inside edges of the layer contents; Outer Bevel
creates a bevel on the outside edges of the layer contents;
Emboss simulates the effect of embossing the layer contents
against the underlying layers; Pillow Emboss simulates the
effect of stamping the edges of the layer contents into the
underlying layers; and Stroke Emboss confines embossing to
the boundaries of a stroke effect applied to the layer. (The
Stroke Emboss effect is not visible if no stroke is applied to
the layer.)

Smooth, Chisel Hard, and Chisel Soft are
available for bevel and emboss effects; Softer and Precise
apply to Inner Glow and Outer Glow effects.Smooth Blurs
the edges of a matte slightly and is useful for all types of
mattes, whether their edges are soft or hard. It does not
preserve detailed features at larger sizes.Chisel Hard Uses a
distance measurement technique and is primarily useful on
hard-edged mattes from anti-aliased shapes such as type. It
preserves detailed features better than the Smooth
technique.Chisel Soft Uses a modified distance
measurement technique and, although not as accurate as
Chisel Hard, is more useful on a larger range of mattes. It
preserves features better than the Smooth technique.Softer
Applies a blur and is useful on all types of mattes, whether
their edges are soft or hard. At larger sizes, Softer does not
preserve detailed features.Precise Uses a distance
measurement technique to create a glow and is primarily
useful on hard-edged mattes from anti-aliased shapes such
as type. It preserves features better than the Softer
technique.

Applies a texture. Use Scale to scale the size of the
texture. Select Link With Layer if you want the texture to
move along with the layer as the layer moves. Invert inverts
the texture. Depth varies the degree and direction (up/down)
to which the texturing is applied. Snap To Origin makes the
origin of the pattern the same as the origin of the document
(if Link With Layer is deselected) or places the origin in the
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upper-left corner of the layer (if Link With Layer is selected).
Drag the texture to position it in the layer.

Modify layer effects with contours

When you create custom layer styles, you can use contours
to control the shape of Drop Shadow, Inner Shadow, Inner
Glow, Outer Glow, Bevel and Emboss, and Satin effects over
a given range. For example, a Linear contour on a Drop
Shadow causes the opacity to drop off in a linear transition.
Use a Custom contour to create a unique shadow transition.

You can select, reset, delete, or change the preview of
contours in the Contour pop‑up panel and Preset Manager.

Detail of Layer Style dialog box for Drop Shadow
effect

A. Click to display the Contour Editor dialog box. B. Click to
display the pop‑up panel. 

Create a custom contour

Select the Drop Shadow, Inner Shadow, Inner Glow,
Outer Glow, Bevel and Emboss, Contour, or Satin
effect in the Layer Style dialog box.

1

Click the contour thumbnail in the Layer Style dialog2
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Load a contour

Delete a contour

Set a global lighting angle for all layers

box.

Click the contour to add points, and drag to adjust
the contour. Or enter values for Input and Output.

3

To create a sharp corner instead of a smooth curve,
select a point and click Corner.

4

To save the contour to a file, click Save and name
the contour.

5

To store a contour as a preset, choose New.6

Click OK. New contours are added at the bottom of
the pop‑up panel.

7

Click the contour in the Layer Style dialog box, and
in the Contour Editor dialog box, and then choose
Load. Go to the folder containing the contour library
you want to load and click Open.

1

Click the inverted arrow next to the currently
selected contour to view the pop‑up panel. Press Alt
(Windows) or Option (Mac OS), and click the
contour you want to delete.

1
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Using global light gives the appearance of a common light
source shining on the image.

Display or hide layer styles

When a layer has a style, an “fx” icon  appears to the right
of the layer’s name in the Layers panel.

Hide or show all layer styles in an image

Expand or collapse layer styles in the Layers
panel

Do one of the following:

Choose Layer > Layer Style > Global Light. In the
Global Light dialog box, enter a value or drag the
angle radius to set the angle and altitude, and
click OK.

In the Layer Style dialog box for Drop Shadow,
Inner Shadow, or Bevel, select Use Global Light.
For Angle, enter a value or drag the radius, and
click OK.

The global lighting applies to each layer effect that
uses the global lighting angle.

1

Choose Layer > Layer Style > Hide All Effects or
Show All Effects.

1

Do one of the following:

Click the triangle  next to the Add A Layer Style
icon  to expand the list of layer effects applied

1
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Copy layer styles

Copying and pasting styles is an easy way to apply the same
effects to multiple layers.

Copy layer styles between layers

Copy layer styles between layers by dragging

to that layer.

Click the triangle to collapse the layer effects.

To expand or collapse all of the layer styles
applied within a group, hold down Alt
(Windows) or Option (Mac OS), and click the
triangle or inverted triangle for the group. The
layer styles applied to all layers within the group
expand or collapse correspondingly.

From the Layers panel, select the layer containing
the style you want to copy.

1

Choose Layer > Layer Style > Copy Layer Style.2

Select the destination layer from the panel, and
choose Layer > Layer Style > Paste Layer Style.
The pasted layer style replaces the existing layer
style on the destination layer or layers.

3

Do one of the following:

In the Layers panel, Alt-drag (Windows) or
Option-drag (Mac OS) a single layer effect from

1
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Scale a layer effect

A layer style may have been fine-tuned for a target
resolution and features of a given size. Using Scale Effects
allows you to scale the effects in the layer style without
scaling the object to which the layer style is applied.

Remove layer effects

You can remove an individual effect from a style applied to a
layer, or remove the entire style from the layer.

Remove an effect from a style

one layer to another to duplicate the layer effect,
or drag the Effects bar from one layer to another
to duplicate the layer style.

Drag one or more layer effects from the Layers
panel to the image to apply the resulting layer
style to the highest layer in the Layers panel that
contains pixels at the drop point.

Select the layer in the Layers panel.1

Choose Layer > Layer Style > Scale Effects.2

Enter a percentage or drag the slider.3

Select Preview to preview the changes in the image.4

Click OK.5
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Remove a style from a layer

Convert a layer style to image layers

To customize or fine-tune the appearance of layer styles, you
can convert the layer styles to regular image layers. After you
convert a layer style to image layers, you can enhance the
result by painting or applying commands and filters.
However, you can no longer edit the layer style on the
original layer, and the layer style no longer updates as you
change the original image layer.

Note:

The layers produced by this process may not result in artwork
that exactly matches the version using layer styles. You may

In the Layers panel, expand the layer style to see its
effects.

1

Drag the effect to the Delete icon .2

In the Layers panel, select the layer containing the
style you want to remove.

1

Do one of the following:

In the Layers panel, drag the Effects bar to the
Delete icon .

Choose Layer > Layer Style > Clear Layer Style.

Select the layer, and then click the Clear Style
button  at the bottom of the Styles panel.

2
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see an alert when you create the new layers.

Create and manage preset styles

You can create a custom style and save it as a preset, which
is then available from the Styles panel. You can save preset
styles in a library and load or remove them from the Styles
panel as you need them.

Create a new preset style

In the Layers panel, select the layer containing the
layer style that you want to convert.

1

Choose Layer > Layer Style > Create Layers.
You can now modify and restack the new layers in
the same way as regular layers. Some effects—
for example, Inner Glow—convert to layers within a
clipping mask.

2

From the Layers panel, select the layer containing
the style that you want to save as a preset.

1

Do one of the following:

Click an empty area of the Styles panel.

Click the Create New Style button at the bottom
of the Styles panel.

Choose New Style from the Styles panel menu.

Choose Layer > Layer Style > Blending Options,
and click New Style in the Layer Style dialog box.

2
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Rename a preset style

Delete a preset style

Enter a name for the preset style, set style options,
and click OK.

3

Do one of the following:

Double-click a style in the Styles panel. If the
Styles panel is set to display styles as
thumbnails, enter a new name in the dialog box
and click OK. Otherwise, type a new name
directly in the Styles panel and press Enter
(Windows) or Return (Mac OS).

Select a style in the Styles area of the Layer Style
dialog box. Then choose Rename Style from the
pop‑up menu, enter a new name, and click OK.

When using a shape or Pen tool, select a style
from the Style pop‑up panel in the options bar.
Then choose Rename Style from the pop‑up
panel menu.

1

Do one of the following:

Drag a style to the Delete icon  at the bottom
of the Styles panel.

Press Alt (Windows) or Option (Mac OS), and
click the layer style in the Styles panel.

Select a style in the Styles area of the Layer Style
dialog box. (See Apply preset styles.) Then
choose Delete Style from the pop‑up menu.

When using a shape or Pen tool, select a style

1
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Save a set of preset styles as a library

Load a library of preset styles

from the Layer Style pop‑up panel in the options
bar. Then choose Delete Style from the pop‑up
panel menu.

Do one of the following:

Choose Save Styles from the Styles panel menu.

Select Styles on the left side of the Layer Style
dialog box. Then choose Save Styles from the
pop‑up menu.

When using a shape or Pen tool, click the layer
style thumbnail in the options bar. Then choose
Save Styles from the pop‑up panel menu.

1

Choose a location for the style library, enter a file
name, and click Save.
You can save the library anywhere. However, if you
place the library file in the Presets/Styles folder
inside the default presets location, the library name
will appear at the bottom of the Styles panel menu
when you restart the application.

Note:

You can also use the Preset Manager to rename,
delete, and save libraries of preset styles.

2
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Click the triangle in the Styles panel, Layer Style1

dialog box, or Layer Style pop‑up panel in the
options bar.

Do one of the following:

Choose Load Styles to add a library to the
current list. Then select the library file you want
to use, and click Load.

Choose Replace Styles to replace the current list
with a different library. Then select the library
file you want to use, and click Load.

Choose a library file (displayed at the bottom of
the panel menu). Then click OK to replace the
current list, or click Append to append the
current list.

2

To return to the default library of preset styles,
choose Reset Styles. You can either replace the
current list or append the default library to the
current list.

Note:

You can also use the Preset Manager to load and
reset style libraries. See Work with the Preset
Manager.

3
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